Render Window

From Planetside Software Wiki
Jump to: navigation, search

Introduction
The Render window displays images during and after rendering. It can be opened several ways :

  • Using the Render View button in the tool bar at the top of the main window
  • Choosing the Render item in the View menu
  • Clicking the Render Image button in the Render Node settings
  • Choosing the Render Current Render Node item in the Project menu

Except for the last method, just opening the Render window does not actually start TG2 rendering. You will need to click the Render button (described below) to start rendering.

A common question that gets asked is what all the little dots which look like stars are when a render has started, but before you actually see complete parts of the render being drawn. These are points in the scene which are used for the global illumination (GI) calculations. How many of the dots you see depends on your GI settings, and if you have GI turned off you won't see any. When the GI calculations are complete the image proper will start rendering and being displayed in the render window.


The Title Bar
The title bar displays several items of information. The most obvious is the render size, for example "640x480". Next to that it will usually display the current zoom level, for example "@ 100%" to show the render is being displayed at full size.

If the image being rendered is larger than can fit on your screen, then while rendering is taking place it is displayed at a reduced size. This is to reduce the amount of memory being used during rendering. The render window is resized as large as possible while still fitting on the screen, and that is used to decide how large to display the image during rendering. When the image being displayed during rendering is smaller than the actual render size, the title bar will display "reduced size" before the zoom percentage. For example, when rendering a 2000 x 1500 image the title bar would read "Render View: 2000x1500 @ reduced size 100%".

When rendering is completed the image is always displayed at full size. If it was larger than could fit on the screen it will initially be zoomed to fit on the screen. You can then use the zoom tools (see the View Manipulation section below) to display it at full size if so desired.

If you are using a pixelA single element of an image which describes values for color and/or intensity, depending on the color system which the image uses. Groups of ordered pixels together form a raster image. aspect ratio other than 1 then the title bar will include a pixelA single element of an image which describes values for color and/or intensity, depending on the color system which the image uses. Groups of ordered pixels together form a raster image. aspect section displaying the width to height ratio of the pixels in the image. As an example, if you are using a pixelA single element of an image which describes values for color and/or intensity, depending on the color system which the image uses. Groups of ordered pixels together form a raster image. aspect ratio of 2 the title bar will including a section saying "(pixelA single element of an image which describes values for color and/or intensity, depending on the color system which the image uses. Groups of ordered pixels together form a raster image. aspect 2:1)".


View Manipulation
There are several ways the render view can be manipulated. The most important is zooming. You can zoom into the image to a maximum zoom of 1200% and out of the image to a minimum zoom of 10%.

Zooming can be done in several ways. You can use the Zoom button at the top of the window (described below), which has a magnifying glass icon. Clicking the button pops up a zoom menu. Context clicking on the image will also bring up the same menu. You can choose from preset zoom levels, or choose the Best Fit item. This will either zoom the image to fit the window or zoom it to 100% (normal size), whichever is smallest.

If you have a mouse wheel you can hold down the option (Mac) or alt (Windows) keys and then use the mouse wheel to zoom in and out of the image. You can also do a windowed, or marquee, zoom by holding down the option or alt keys and then clicking and dragging with the left mouse button (or just the mouse button if you use a single button mouse) over the area of the image you want to zoom in on.

There are several ways you can scroll or pan around the image. The most obvious is the scroll bars. You can use the mouse wheel to scroll up and down. If your mouse wheel supports sideways scrolling you can use that to scroll the image left and right, or else you can also hold down the shift key down while rolling the mouse wheel up and down. Clicking and dragging on the image will also allow you to pan around the image.

Please note, the key and mouse controls described above may change depending on the settings you are using in the Input Settings preference panel. To see the key and mouse combinations you can use to interact with the render view, open the Mouse and Key Settings dialog from the Help menu and look in the Render View section.


Window Controls
These are the controls you can see along the top of the Render window:

  • Render/Pause button: Before rendering has started this button is labelled Render. Clicking the button will start rendering the scene using the last selected render nodeA single object or device in the node network which generates or modifies data and may accept input data or create output data or both, depending on its function. Nodes usually have their own settings which control the data they create or how they modify data passing through them. Nodes are connected together in a network to perform work in a network-based user interface. In Terragen 2 nodes are connected together to describe a scene.. When rendering is underway, the button label changes to Pause. Clicking it now will pause the render. While the render is paused the button label reads PAUSED. When you click it again the rendering will resume.
  • Save/Stop button: When a render is able to be saved as an image file, generally after has completed or has been stopped, this button will be enabled and labelled Save.... If it is not possible to save an image, the button is disabled. While rendering is underway the button is labelled Stop and clicking it will stop the render.

  • Zoom button: The Zoom button has a small magnifying glass icon. Clicking on it pops up a menu which lets you from a selection of zoom levels. There is also a Best Fit option, which will either zoom the image to fit the window or zoom it to 100% (normal size), whichever is smallest.

  • Status text: The status text item displays different things at different stages of rendering. Often it is blank. During rendering it says "Rendering" along with the elapsed render time. If the render is paused it will say "PAUSED render". If the render has been stopped before it was completed it will say "Aborted render".


Back to Window Reference