Author Topic: Importing terrains and textures from Geocontrol  (Read 5276 times)

Offline rtg497

  • Member
  • *
  • Posts: 11
Importing terrains and textures from Geocontrol
« on: January 07, 2010, 07:29:33 PM »

Can anyone tell me how to get a terrain to match up with the texture when you import from Geocontrol?  I export as 4096 resolution but when I get them into Terragen, the terrain shows up in one small section of the area in the preview window.   The texture (which I connect as a Image file) covers the total area rather than just the terrain I just brought in.  That part makes sense because it's applying the texture to the whole area.  I don't understand how to make it just give me the terrain that I imported.  Thanks in advance.


Offline Tangled-Universe

  • Terrevangelist
  • *
  • Posts: 6089
    • - Terragen Tutorials!
Re: Importing terrains and textures from Geocontrol
« Reply #1 on: January 07, 2010, 08:02:20 PM »
First you have to know the size of your terrain in metres. Then in the heightfield-load node enter that size in the heightfield-size boxes.
If you don't care about the real-world size of your terrain from GC then load the terrain file and add a heightfield resize operator between the heightfield load and heightfield shader.
In the resize operator set your desired size of the terrain, say 10000x10000m (10x10km) for example.

We consider now, regardless how you do the above steps, that your terrain is 10x10km.

If you look in the heightfieldshader you will see that the position is at 0,0,0 and set to bottom left, which means that the bottom left part of your terrain starts at position 0,0,0.

When you load your mask into an imagemap, select Plan Y projection. Set the size to the size of your terrain, which is 10000x10000m (enter it in metres!).
Make sure the projection is also set to "bottom" left.
Your image is now projected in plan y on top of your terrain. You don't have to specify your camera.

Generally when you use maps from world-machine you need to flip these on the y-axis in your image-map shader to match the terrain, but I don't know how that is with GC.
Set up an orthographic camera and check if the orientation is ok.
You can do this by using the output of the image-map shader as blendshader for a surface layer. Enable the test color of the surfacelayer and make sure "blend by shader" is enabled.
In orthographic view you should now be able to check if your map is placed correctly.

If your map does not show up at all, then make sure if it is really black & white. World-Machine generated masks need equalization before usage or you can equalize them in TG2 using the color-adjust shader (reduce white point).

Hopefully this all helps.


Offline rtg497

  • Member
  • *
  • Posts: 11
Re: Importing terrains and textures from Geocontrol
« Reply #2 on: January 07, 2010, 09:12:23 PM »
I think I may love you.  lol..  I'll try that now.  Thanks a lot.

Offline Oshyan

  • Planetside Staff
  • *
  • Posts: 12200
  • Holy snagging ducks!
Re: Importing terrains and textures from Geocontrol
« Reply #3 on: January 10, 2010, 04:32:12 AM »
If you run into any more issues, try a search for Geocontrol here in the forums. There has been lots of informative prior discussion and troubleshooting.

- Oshyan