Author Topic: Not enough memory to save  (Read 4895 times)

Offline StickerSticker

  • Member
  • *
  • Posts: 15
    • My Deviantart Page
Not enough memory to save
« on: January 23, 2008, 08:00:04 PM »
I'm attempting to save a large render of mine, but the program tells me i don't have enough memory, and i should close some programs... Terragen is using 1/3 of my total RAM right now, but i closed everything anyway, and it still won't save.


Is the image stored in a temp folder somewhere i can get it?

Offline Oshyan

  • Planetside Staff
  • *
  • Posts: 8815
  • Holy snagging ducks!
Re: Not enough memory to save
« Reply #1 on: January 23, 2008, 10:51:42 PM »
Unfortunately Terragen 0.9 does not automatically save images or use any temp files when rendering. Closing down programs *after* you have rendered in order to save usually doesn't work. The only thing that *may* work is restarting, re-rendering, and keeping all other programs closed. Setting the render buffer to 5MB or so can also help on very large images. Reducing other detail in the scene, for example terrain size (if you are using 2049 or above), or various antialiasing settings, can help as well.

However you may simply be rendering beyond the practical limits of TG 0.9's rendering engine. On Windows it is about 11,500x11,500 pixels. On the Mac it can be much higher and you also have the option to render to disk, which can allow even larger images.

- Oshyan

Offline StickerSticker

  • Member
  • *
  • Posts: 15
    • My Deviantart Page
Re: Not enough memory to save
« Reply #2 on: January 23, 2008, 10:56:03 PM »
ah, it was 12,800*9,600... so that explains that.

thanks

Offline Oshyan

  • Planetside Staff
  • *
  • Posts: 8815
  • Holy snagging ducks!
Re: Not enough memory to save
« Reply #3 on: January 23, 2008, 11:01:31 PM »
Technically the 11,500 square limit is above your render in total number of pixels so there may still be hope, provided you have 2+GB of memory. Set the render buffer to 5MB and make sure Extra Blended Detail is off - also may want to turn off Ultra Antialiasing. Then it may work...

- Oshyan

 

anything