Author Topic: Flat Earth Syndrome  (Read 5686 times)

Offline JT

  • Member
  • *
  • Posts: 5
    • That Canvas Shop
Flat Earth Syndrome
« on: December 21, 2006, 10:23:10 PM »
I do a lot of seacape panoramas and I am having trouble getting a nice straight horizon on my seas. I have tried making the planet really big and getting the camera low to the ground but I still get the planet curve on the horizon. Anyone got any suggestions?

Many Thanks
JT

Offline Matt

  • Planetside Staff
  • *
  • Posts: 2878
  • I'm the crazy one
Re: Flat Earth Syndrome
« Reply #1 on: December 21, 2006, 10:43:32 PM »
I removed by previous reply because I think I might have been talking nonsense...  :-[
Just because milk is white doesn't mean that clouds are made of milk.

Offline Matt

  • Planetside Staff
  • *
  • Posts: 2878
  • I'm the crazy one
Re: Flat Earth Syndrome
« Reply #2 on: December 21, 2006, 10:44:05 PM »
Can you show us an example?
Just because milk is white doesn't mean that clouds are made of milk.

Offline 3DGuy

  • Member
  • *
  • Posts: 340
    • The Glass Eye Photography
Re: Flat Earth Syndrome
« Reply #3 on: December 21, 2006, 11:12:22 PM »
Being a photographer I think I know what your problem is. If it were a real camera I'd say you're using a wideangle lens. So in this case I'd suggest to lower your render FOV. So goto the camera tab, select the render camera and set the horizontal FOV to a lower value. Also having the horizon not in the middle will enhance the effect, at least with real camera's. So if you don't want to lower your FOV, try setting your horizon smack in the middle.

Offline JT

  • Member
  • *
  • Posts: 5
    • That Canvas Shop
Re: Flat Earth Syndrome
« Reply #4 on: December 22, 2006, 12:55:46 AM »


Matt, here is the requested example. Ignore the gray areas as the render was done in 3 parts for a 3 part canvas panel print. The gray bits are just my Photoshop backgroung colour. Just the effected area of the image is shown cropped down in PS. I have drawn a blue line starting at the left hand end of the horizon so that you can see the deviation. I suspect that the is not a lot I can do about this in Terragen 2 as the whole system is based on planets.

I have just done an edit in Photoshop and used the lens correction filter to straighten out the curviture deviation and it works quite well, but it does have to mess with the pixels so it is not ideal. My next problem is getting my camera centred correctly to the axis of the planet as, as you can see in the image not only am I getting a curved horizon but the two extreme ends of the horizon are also not lined up. Hope I am making sense!

Anyway, I have now gone from having Flat Earth Syndrome to being Lost in Space! lol

3DGuy, I have tried the narrowing the FOV out already but I get too zoomed and loose the effect I am after. I did this once on a render in 0.9 and the zooming created a big loss of detail and added pixelation. Might be worth trying out in 2 to see if procedural surfaces give the same effect.

Offline Oshyan

  • Planetside Staff
  • *
  • Posts: 11872
  • Holy snagging ducks!
Re: Flat Earth Syndrome
« Reply #5 on: December 22, 2006, 01:38:53 AM »
I'm fairly sure if you just remove the Planet name in the Planet tab of the Lake object then it will not be curved to follow the planet. Give it a shot.

- Oshyan

Offline JT

  • Member
  • *
  • Posts: 5
    • That Canvas Shop
Re: Flat Earth Syndrome
« Reply #6 on: December 22, 2006, 02:30:13 PM »
Thanks Oshyan

That works a treat. I also discovered that depending on your height above the lake object it may be necessary to also increase its radius to get a nice straight horizon.