Author Topic: Spherical Cameras Vs Preview  (Read 715 times)

Offline ajcgi

  • Terragen Alpha Tester (Mac)
  • ***
  • Posts: 575
    • My little blogsite
Spherical Cameras Vs Preview
« on: February 19, 2018, 05:30:20 PM »
Seems I've found another 3D Preview issue. Has anybody had trouble with the spherical camera lately?
I've a scene here that flatly refused to render, then it wouldn't render if the camera was below zero in Y, even if the local landscape was all -500m. It would struggle, slow down in the middle strip of the render, then stop.
It seems that if the 3D preview hasn't begun a new round of previewing and got past the Detail level 5, then there are issues with the spherical camera render in my scene. I'm wondering if there's a point where the camera says, "Hey I appear to be under the ground. I will presume I am," unless the preview has begun and it knows otherwise? I can't post the exact scene here, but could potentially email it over to Planetside staff.

Offline luvsmuzik

  • Member
  • *
  • Posts: 2830
    • luvsmuzik 1995
Re: Spherical Cameras Vs Preview
« Reply #1 on: February 19, 2018, 07:11:28 PM »
Probably doesn't matter a hill of beans, but if you are using TG terrain, is your fractal setting modulator, clamped or unclamped? I sometimes get variations when changing those settings. I can't do spherical render so it is probably something else. My regular underwater renders do just fine below 0 alt.

Offline KlausK

  • Member
  • *
  • Posts: 434
  • Land ho!
Re: Spherical Cameras Vs Preview
« Reply #2 on: February 19, 2018, 09:07:10 PM »
Hi,
not sure how I could assist here but I never experienced this.
Attached 2 renders with the spherical camera "inside" the planet below the ground terrain.
I tried to pause the preview and then move the camera below the terrain.
Without releasing the 3D preview the render worked in every test.
This is only a "light" default default scene.
Let me know if you want me to test any specific workflow to recreate the erratic behaviour.
CHeers, Klaus
/ ASUS WS Mainboard / Dual XEON E5-2640v3 / 64GB RAM / NVIDIA GeForce GTX 780 / Win7 Ultimate

Offline ajcgi

  • Terragen Alpha Tester (Mac)
  • ***
  • Posts: 575
    • My little blogsite
Re: Spherical Cameras Vs Preview
« Reply #3 on: February 20, 2018, 09:36:49 AM »
Cheers both.
@KlausK I set up a similar scene myself and no problems whatsoever.
@luvsmuzik That's an interesting point. I don't usually use built in terrain generator nodes and in fact this scene has DEM as its base, but it does have fractals on top, some with their displacement set to spike limits higher than I'd usually go just because they look pretty frankly!

I'll keep an eye on the scene as the project progresses and let you all know if I truly figure out what is amiss here.

Offline Oshyan

  • Planetside Staff
  • *
  • Posts: 12654
  • Holy snagging ducks!
Re: Spherical Cameras Vs Preview
« Reply #4 on: February 20, 2018, 08:10:01 PM »
Send it over to support if you continue having the issue. If we can reproduce it here, we can often determine the cause, even if it's "bad settings" or something like that.

- Oshyan

Offline ajcgi

  • Terragen Alpha Tester (Mac)
  • ***
  • Posts: 575
    • My little blogsite
Re: Spherical Cameras Vs Preview
« Reply #5 on: February 21, 2018, 12:41:09 PM »
Cheers Oshyan,

If it comes to it, what is the best address to send something over to?

Offline Oshyan

  • Planetside Staff
  • *
  • Posts: 12654
  • Holy snagging ducks!
Re: Spherical Cameras Vs Preview
« Reply #6 on: February 21, 2018, 09:15:51 PM »
support AT planetside.co.uk as ever :)

- Oshyan

 

anything