Author Topic: Imported 3D models look very low quality  (Read 258 times)

Offline Xenoyia

  • Member
  • *
  • Posts: 11
  • Photographer, musician and programmer.
    • Web Portfolio
Imported 3D models look very low quality
« on: November 30, 2017, 10:32:03 PM »
Hello,

I'm new to terragen, CGI and 3d modelling in general. I have a big question that I can't seem to find the answer to anywhere on here.. I hope someone can help!





I have this 3D model, it's very high resolution and the folder contains a bunch of texture files, which I assumed is all that Terragen needs.. Now I might be a bit naive and not used to this stuff, but how come when I import it and render at full resolution/quality, it looks more like a plastic toy car with random black parts? No metallic quality to anything, windows look frozen, no headlights or license plate..



I'm sure I'm missing something simple here, but I am very new to this so it's all very confusing to me.

Thanks in advance!
Luke

Photography/Music Portfolio: http://lukevalentine.co.uk/

Offline Dune

  • Member
  • *
  • Posts: 12826
  • Corkscrew Bird
    • www.ulco-art.nl
Re: Imported 3D models look very low quality
« Reply #1 on: December 01, 2017, 06:44:24 AM »
First of all, welcome.

You have to check inside the object node for links to various textures. It looks like some are missing. TG doesn't import all perfectly yet.

Then; if you need really transparent glass, you'll need to add a glass shader to the part in your car, not the default shader that's now attached.

For reflection of the car body, you'll have to add a reflective shader set to RayTraced  (which is default) between part and defaults hader that contains the color/texture, but you should also change the refraction index to one for metallic (higher). There are some tgc's around that you may find usefull. Just use the search function for metallic or something.

Tires' default shader may also need a darker color and perhaps a dull reflection (no-RT), experiment with values.
In case you still haven't seen enough of my work: www.ulco-art.nl

Offline Hetzen

  • Member
  • *
  • Posts: 1539
Re: Imported 3D models look very low quality
« Reply #2 on: December 01, 2017, 09:12:11 AM »
I also think that your model may have used a different shader set up other than a 'standard material'

What program was the model made in? And what formats did it offer for download?

Offline digitalguru

  • Member
  • *
  • Posts: 198
Re: Imported 3D models look very low quality
« Reply #3 on: December 01, 2017, 09:27:47 AM »
Unfortunately there's a whole lot of work to restore the look of your model in Terragen. The random black parts I'm guessing are where the model had a shiny chrome like shader attached, since there's no reflective shader attached by default(when the model is imported into Terragen), the shader returns the diffuse value for chrome like metal which would be (almost) black.

p.s. It would be great to put on the road map for TG an "Uber" or monolithic shader with raytraced specular/reflections built in - would make translating these type of models a bit more streamlined? - or since these are usually .obj models with an associated .mtl file would it not have enough info?
« Last Edit: December 01, 2017, 10:01:28 AM by digitalguru »

Online cyphyr

  • Member
  • *
  • Posts: 3585
    • richardfraser
Re: Imported 3D models look very low quality
« Reply #4 on: December 01, 2017, 10:05:42 AM »
Just stating the obvious for completeness.
The surface shaders are hidden "inside" the model node. Look to the top right of the node panel and double click on the "+" symbol. Inside there is a "Parts" node and inside there are your various surface shaders.

You will need to rebuild the shader network to make something similar to your original model. Search the forum for "car paint" and "windows" etc. For the normal maps you will also have to either use vector displacement (again search for detailed instructions) or convert them into grey scale bump maps or displacement maps. The number plate should be working so check the path is correct.
www.richardfraser.co.uk
/|\

i7 5930 @3.5Ghz, 32Gb
i7 2600k @3.4Ghz, 16Gb
i7 980 @3.33Ghz, 16Gb

Offline luvsmuzik

  • Member
  • *
  • Posts: 1595
Re: Imported 3D models look very low quality
« Reply #5 on: December 01, 2017, 11:51:01 AM »
Welcome also! Check here for some great examples.
http://www.planetside.co.uk/forums/index.php/topic,22695.0.html

Hannes has made a set of example materials with application. To utilize these, download the library of Materials tgc, and store them in you clip files folder of Terragen program. Then when you are in your object node setup for material, insert a clip file tgc., (using the appropriate tgc for each material) You can add a transform input node before surface shader (set to world position) Transform input gives you a little control over the material, especially scale.
« Last Edit: December 01, 2017, 12:04:42 PM by luvsmuzik »

Offline Xenoyia

  • Member
  • *
  • Posts: 11
  • Photographer, musician and programmer.
    • Web Portfolio
Re: Imported 3D models look very low quality
« Reply #6 on: December 01, 2017, 06:24:46 PM »
Omg I love you guys.

Thanks so much for the help, I already feel like I'm making so much progress when I've been stuck in a rut for weeks over this project.



Certainly a lot better looking now :D Some issues still with the defraction on the glass, but I think I'm using the wrong shader for it or just missing a setting somewhere.
Photography/Music Portfolio: http://lukevalentine.co.uk/

Offline luvsmuzik

  • Member
  • *
  • Posts: 1595
Re: Imported 3D models look very low quality
« Reply #7 on: December 01, 2017, 11:59:18 PM »
Well done!

Offline bobbystahr

  • Member
  • *
  • Posts: 8204
  • Turn, and face the Strange Ch Ch Changes...D Bowie
Re: Imported 3D models look very low quality
« Reply #8 on: December 02, 2017, 01:30:44 AM »
Much better. Sometimes glass works best as a completely separate object with Cast Shadows turned off. It used to be necessary but not too much so now. What I do is I duplicate the model (C&P) and in one I turn all shaders except the glass ones to 0 opacity and turn cast shadows off on that model and you already have the glass shader, make sure double sided  clicked, and in the car part do the same for the glass parts.
« Last Edit: December 02, 2017, 01:32:15 AM by bobbystahr »
something borrowed,
something Blue.
Ring out the Old.
Bring in the New

bobbystahr