Author Topic: possible bugs in TG2  (Read 6899 times)

Offline jean-claude

  • Member
  • *
  • Posts: 1
possible bugs in TG2
« on: December 21, 2006, 08:22:50 AM »
As an alpha-tester I think the first thing to test is if the program can correctly do some elementary tasks.

So I've made a terrain 40974097 with GeoControl, I've named it "020Geo_06-12-20_21h12.ter" (later on I simplified the name as "GC247_aabc.ter", but it's the same terrain file)
I've uploaded this terrain in Terragen 2 v1.8.56.2
I've choosen very elementary settings ("GC247_aabc_012.tgd") for a Full Render 2048 1536 pixels.
I've named this render "GC247_aabc_012_3h32m19s_9442444_micro-triangles.bmp", because the render Time was 3:32:19 for 9,442,444 micro-triangles.


When I scrupulously examine the obtained image in my Photoshop (fig. 00 only shows a 35% reduced view of the render), there are numerous defects, probably coming from some bugs in the program:

1. numerous whitish spots in shadowed areas, some of them visible even without zooming (some examples on fig. 01)

2. other strange things (fig. 02 is a 50% view in Photoshop) :
of which the most strange is perhaps the arch seen on a 400% view (fig. 03, #3)
fig. 04 is a 200% view of a strange overhang near a flat horizontal zone (#2)
fig. 05 is a 500% view of an antialiasing problem (#1)
fig. 06 is a 400% view of 2 strange nearly square light zones, principally the lower one (#4)
fig. 07 is a 300% view of strange chinese or hieroglyphic character in a shadow zone (#5)

I've send to Matt in a private email
the address for downloading the terrain (*.ter), the *.tgd and the *.bmp files

Offline Oshyan

  • Planetside Staff
  • *
  • Posts: 11685
  • Holy snagging ducks!
Re: possible bugs in TG2
« Reply #1 on: December 21, 2006, 08:25:59 AM »
Thank you for the bug report. However please do make sure to run all tests on the latest versions available which as of this writing is 1.8.64.0. Also note that non-public alpha test versions should be discussed in the appropriate forum, not here.

- Oshyan

Offline boristen

  • Member
  • *
  • Posts: 1
Re: possible bugs in TG2
« Reply #2 on: December 21, 2006, 08:53:28 AM »
One of my first renders in TG2 showed similar (suppose rectangular) defects.

Offline hansiMUC

  • Member
  • *
  • Posts: 10
    • Circles & Lines
Command line rendering in Deep version 1.8.64.0 is not working
« Reply #3 on: December 21, 2006, 12:15:15 PM »
How shall we report bugs or let's call them unsolved problems... ?
Here in a consecutive list of issues we find, one thread per bug or is there a specific approach ?

First, we tried in Deep version 1.8.64.0 the command line in tgd and tgdcli and somehow didn't succeed in getting the program rendering without opening the gui.
we used the following commandline:

tgdcli.exe y:\projects\wdw\..some long path..\srtm\version2\SRTM3\Eiger_Munich\terragen\alpen_02.tgd -r -exit -hide -f 15 -o c:\temp\bild.%04d.bmp

We also set the environment variable TERRAGEN_PATH, tried it from the program folder but somehow didn't succeed...
Any help/hints ?



Offline Oshyan

  • Planetside Staff
  • *
  • Posts: 11685
  • Holy snagging ducks!
Re: possible bugs in TG2
« Reply #4 on: December 21, 2006, 06:04:38 PM »
Please report bugs with a new post for each bug, being sure to search the forums first to verify that it hasn't been already reported.

Thanks!

- Oshyan