Author Topic: TG4 crashing upon importing object from library  (Read 299 times)

Offline ckinsel

  • Member
  • *
  • Posts: 2
TG4 crashing upon importing object from library
« on: August 29, 2017, 10:03:49 PM »
I'm new to TG, and have been running into issues importing files from the library.  I've populated the Library with free samples of Xplant and the Silva3D Plant Model Sampler hosted on the Planetside site. Between the two packs, I have both .TGO and .OBJ files, but when I select either type, it crashes Terragen completely. The same happens even if I specifically use the .TGO or .OBJ reader within the object menu.

Am I doing something wrong? Can someone provide assistance?

Offline Oshyan

  • Planetside Staff
  • *
  • Posts: 11746
  • Holy snagging ducks!
Re: TG4 crashing upon importing object from library
« Reply #1 on: September 01, 2017, 08:32:59 AM »
Can you try closing the 3D Previews before importing/loading your object? There are two steps. First, use the X (close) button on the upper-right of the main 3D Preview. Then, switch to the Objects Layout, if you are not already on it (using the Objects button on the top toolbar). Now, at the top of the Node List on the left you'll see a button, "Add Object". To the right of that is an unlabeled button that gives you a tooltip if you hover over it explaining that it enables/disables the object preview window. Click it to disable the object preview window to the right. Once both are closed, try loading your object(s) again and let us know if that changes anything.

- Oshyan

Offline ckinsel

  • Member
  • *
  • Posts: 2
Re: TG4 crashing upon importing object from library
« Reply #2 on: September 01, 2017, 02:23:18 PM »
Thanks for the fast reply Oshyan!

Disabling the 3D and Object preview windows allowed me to import both .TGO and .OBJ objects, however when I go to open the 3D preview again, it crashes.
After importing, but before re-enabling 3D view, I've even tried disabling the object, changing it to "hidden", and disabling the sub-object shaders, but am getting the same crash when trying to preview via 3D or Object views.
It also seems, with the 3D and Object preview windows closed, I am even able to render a scene with the imported objects. Meaning it is able to read the file + textures without issue, and seems to only crash when displaying to the preview windows.

Perhaps you can try importing one of the files that I'm trying to use, to see if you get any similar issue? Maybe my file is out-of-date and I just don't know it.

Thanks!

Offline Kadri

  • Member
  • *
  • Posts: 7844
Re: TG4 crashing upon importing object from library
« Reply #3 on: September 01, 2017, 04:55:42 PM »

The object works fine here (Terragen v4.1.11, Windows 10)
Is your graphics driver up to date?

Offline Oshyan

  • Planetside Staff
  • *
  • Posts: 11746
  • Holy snagging ducks!
Re: TG4 crashing upon importing object from library
« Reply #4 on: September 02, 2017, 09:32:00 AM »
Yes, this is not an issue we can reproduce because it is most likely due to some specific issues with your graphics driver and/or adapter. Unfortunately the latest drivers are not always the best, but you can try checking for updates to see if that helps.

- Oshyan