Author Topic: TG 4.1.11 file open failing  (Read 244 times)

Offline FlynnAD

  • Member
  • *
  • Posts: 71
TG 4.1.11 file open failing
« on: August 15, 2017, 01:43:56 AM »
I just upgraded TG 4.0.0.4 (I think) to 4.1.11. The program opens fine and everything looks good.

When a specific file from v4.0 is opened, the camera preview screen does not ever completely load (it does not show anything at all), and the application is basically hanging with a spinning cursor wheel. Up top, next to the Pause/ Reset/ RTP and subsequent icons, is the text "Aborting threads..."

The only thing that I can think of is that there are two large DEM heightfields that are loaded that are conflicting with version 4.1.11.

I've opened other v4.0.0.4 files without these DEM heightfields and they're fine. I've opened up other earlier saved versions of the offending file, still with the two DEM heightfields, and those earlier version files also hang.

The only other thing I can think of is a potential graphics card issue, as I upgraded the graphics card driver at the same time as installing the TG4.1.11 update, and without ever trying to open the file in question between the two upgrades. I'm using an nVidia Geforce GTX 1070 with the latest driver 384.94.

Any idea what is going on?

Thanks,
Matt
« Last Edit: August 15, 2017, 01:48:46 AM by FlynnAD »

Offline Oshyan

  • Planetside Staff
  • *
  • Posts: 11641
  • Holy snagging ducks!
Re: TG 4.1.11 file open failing
« Reply #1 on: August 15, 2017, 08:19:41 AM »
Hi Matt,

Can you try a couple things. 1: open a new, blank TG4 scene and load the same DEMs that are giving you trouble. Does the same issue occur? 2: start TG and then close the 3D preview window (x on the window upper-right) and then load your project again and see if it still occurs.

There were no DEM loading changes in 4.1 as far as I'm aware but there were changes to the previews (none of which I would think would cause such issues, but you never know). How large are the DEMs? What else is in the scene you are loading and what are the detail and quality/sample settings for any cloud layers, atmosphere, etc?

- Oshyan

Offline FlynnAD

  • Member
  • *
  • Posts: 71
Re: TG 4.1.11 file open failing
« Reply #2 on: August 15, 2017, 05:13:17 PM »
Hi Oshyan,

Troubleshooting results:

First off, for #2, the only way to get the file to open was to close the preview window while the DEMs were loading, or cancel the DEMs loading themselves. After that, playing with the file and opening the preview window went fine and yielded no errors, until that file was saved and re-opened. Then, again, it did not open.

So, trying #1, I put each of the heightfield and heightfield loaders into TG clips and loaded them individually into a fresh file. The end result is that they can both be inserted into the file, they can both be turned on, they can each themself be plugged into the Compute Terrain node, but when one heightfield is plugged into the second heightfield (in either order), and then into the Compute Terrain, while the result will properly show and work in the preview window, upon saving, closing, and re-opening the file, it will crash.

So somehow, having both heightfields plugged into each other is causing the issue in TG4.1.11. Occasionally, TG will simply give the preview window message "Aborting threads" and hang. At other failed attempts, TG gave the error message "An unknown error occurred in trBucketRender::RenderMore() rasterized pass      floatn3" without completing the preview window (it remained gray).

Does that help figure out what it is?

Thanks,
Matt

ADDITIONALLY: The two DEMs are 450 MB each, but this made no impact on TG4.0.0.4, and I had been using the same file in TG3.
« Last Edit: August 15, 2017, 08:27:44 PM by FlynnAD »

Offline Oshyan

  • Planetside Staff
  • *
  • Posts: 11641
  • Holy snagging ducks!
Re: TG 4.1.11 file open failing
« Reply #3 on: August 20, 2017, 06:25:58 PM »
Thanks much for those details! And apologies for the delayed reply. Could you send us a TGD and, if possible, either 7-zip archive the DEMs, or point us to where they might be downloaded to duplicate this issue? support AT planetside.co.uk

- Oshyan