Author Topic: OBJ Motion blur problems  (Read 574 times)

Offline rolland1013

  • Member
  • *
  • Posts: 28
OBJ Motion blur problems
« on: August 07, 2017, 06:08:12 PM »
I've been doing some testing with importing OBJ files into Terragen and have run into a problem.  When I render a scene with motion blur enabled I am getting a weird blur problem on the OBJ objects.  It looks kind of like the frame sampling is wrong.  Any ideas on how to fix this? 

Thanks,
Niel

Offline Oshyan

  • Planetside Staff
  • *
  • Posts: 11779
  • Holy snagging ducks!
Re: OBJ Motion blur problems
« Reply #1 on: August 07, 2017, 10:23:26 PM »
I guess they are responding to the camera motion blur, perhaps since object motion blur is not yet available in Terragen. Odd though, I'm pretty sure I've seen similar camera moves with synced objects that do not have this issue. I would try turning off the blur and see if there is a noticeable difference with the background and if not just leave it off.

Another thought occurred to me, if you are using the 2D blur, try the 3D and see if it's better...

By the way your clouds look great!

- Oshyan

Offline rolland1013

  • Member
  • *
  • Posts: 28
Re: OBJ Motion blur problems
« Reply #2 on: August 07, 2017, 11:21:43 PM »
Thanks for the compliment on the clouds.  I wish I could take credit for them.  They're just the standard low-level cumulus medium clouds.  I haven't tweaked anything with them yet.  But yeah I agree they look pretty cool, you guys do great work!  ;)

I was using 3D motion blur for that render, maybe I'll try 2D to see what happens.

Another issue has come up with this file.  The aircraft in the shot was downloaded off a modeling website, for the most part the textures linked up the way they should.  But when I opened the aircraft model in Maya to make some changes (just raising the landing gear) and then saved it out as an OBJ file, the textures didn't link up anymore.  In fact the names are now different within Terragen.  I'm not sure what is going on.  Is there a preferred program to export OBJ files from that I should be using?  Also when I try to adjust the transparency of the windows on the model I can't seem to get anything other than fully transparent, or fully opaque, again, not sure what's going on there.

Thanks,
Niel

Thanks,
Niel


Offline Dune

  • Member
  • *
  • Posts: 12803
  • Corkscrew Bird
    • www.ulco-art.nl
Re: OBJ Motion blur problems
« Reply #3 on: August 08, 2017, 06:40:01 AM »
You could try and take the model trough Poseray, check all textures and maps and save again. Regarding transparent windows; the default shader's opacity is either black or white, no gradient. So you'd have to use a glass shader instead. But another problem is the shadow; an object either makes a shadow or not, so if you want to have the plane making shadows, but the glass oviously not, you'd have to save them as separate objects, and set respective shadows on or off.
In case you still haven't seen enough of my work: www.ulco-art.nl

Offline bobbystahr

  • Member
  • *
  • Posts: 8187
  • Turn, and face the Strange Ch Ch Changes...D Bowie
Re: OBJ Motion blur problems
« Reply #4 on: August 14, 2017, 07:18:31 PM »
You could try and take the model trough Poseray, check all textures and maps and save again. Regarding transparent windows; the default shader's opacity is either black or white, no gradient. So you'd have to use a glass shader instead. But another problem is the shadow; an object either makes a shadow or not, so if you want to have the plane making shadows, but the glass oviously not, you'd have to save them as separate objects, and set respective shadows on or off.

Yup Dune nailed all the issues well.
something borrowed,
something Blue.
Ring out the Old.
Bring in the New

bobbystahr

Offline rolland1013

  • Member
  • *
  • Posts: 28
Re: OBJ Motion blur problems
« Reply #5 on: August 25, 2017, 12:15:43 AM »
I haven't tried Poseray, but I did try 3D StudioMax and that seemed to fix the texturing issue.  I'll try Poseray just to see if there's any advantage.  I also tried swapping out my window textures for the glass shader and that worked!  Thanks Dune.

Niel

Offline digitalguru

  • Member
  • *
  • Posts: 198
Re: OBJ Motion blur problems
« Reply #6 on: September 14, 2017, 09:48:48 PM »
As Oshyan says you can't motion blur an imported .obj in Terragen.

I would render your obj animation in a 3d package and comp the results, but alternatively you could render a .tgSurf2dMotion render element  of your model in Terragen and use that in a comp application to vector blur the 3d model.