Author Topic: entering the values numericly in the atmosphere height control haze crashes terr  (Read 216 times)

Offline Prometheus

  • Member
  • *
  • Posts: 7
 I get constant crashes on terragen 4.1 when trying to enter  the values numericly in the atmosphere height control haze exp height and also bluesky exp height, rtp is active while doing so.
Hower using the sliders to change the values do not crash terragen.

Offline jaf

  • Member
  • *
  • Posts: 631
Yes, I saw that yesterday.  Thought I miss-typed, but just tried it again and got the crash.
(6/14/17) Ryzen 1800x, 960 EVO 500GB NVME-M.2 SSD, Corsair Vengeance 64GB DDR4 3200 Mem,  EVGA GeForce GTX 1080 Ti FTW3 Graphics, Win 10 Pro x64, Terragen 4.1.11

Offline Oshyan

  • Planetside Staff
  • *
  • Posts: 11544
  • Holy snagging ducks!
Any particular values? I see that using "extreme" values (e.g. 1) can sometimes either cause the RTP to go black and not recover (even if normal values are re-entered), or crash (especially in the case of really extreme values like 1). Were you using weird/crazy/extreme values, or more normal ones? The sliders keep you to normal values, which might explain why it doesn't crash in that case.

If you're using strange values then try doing it with the regular preview (not RTP), and you may get "ray trace errors" of some kind, which would help explain and diagnose what's going on. If you don't get those errors with the regular preview and the RTP still crashes with the same value(s) entered that would be interesting, we haven't been able to duplicate that yet.

- Oshyan

Offline jaf

  • Member
  • *
  • Posts: 631
Seeing the post by Prometheus reminded me that TG4 (4.1.11 x64) crashed once a couple days ago when I was setting the Atmosphere Haze density to 5 (typing, not slider.) However, I working fast and not paying as much attention as I would if troubleshooting a problem.  I reloaded the scene and had no problem setting the atmosphere haze density, so I assumed I had miss-typed.
(6/14/17) Ryzen 1800x, 960 EVO 500GB NVME-M.2 SSD, Corsair Vengeance 64GB DDR4 3200 Mem,  EVGA GeForce GTX 1080 Ti FTW3 Graphics, Win 10 Pro x64, Terragen 4.1.11

Offline Oshyan

  • Planetside Staff
  • *
  • Posts: 11544
  • Holy snagging ducks!
Interesting, thanks for the report. Definitely let us know if you can reproduce this reliably with specific steps/settings. So far we haven't been able to here, but it's possible there's a bug and if so we'd like to squash it. :D

- Oshyan

Offline icarus51

  • Member
  • *
  • Posts: 80
Hi all,

I tried these typing with RTP, no RTP, Haze exp, Haze height control and Bluesky but No crash at all even with anormal values. I hope this helps.

Offline Oshyan

  • Planetside Staff
  • *
  • Posts: 11544
  • Holy snagging ducks!
Thanks for testing it as well icararus. Hopefully we can track down the source of any problems Prometheus is having. It may be due to graphics driver, for example, or something else...

- Oshyan

 

anything