Author Topic: Terragen 4 performance  (Read 1494 times)

Offline Lieutenant-Dingo

  • Member
  • *
  • Posts: 2
Terragen 4 performance
« on: May 28, 2017, 01:27:14 AM »
Im new to terragen, and am wondering whether the render times I am getting are normal, as they are quite long. I have an i5-4690k at 3.5 Ghz, 16 Gb ram at 2133 mhz, and a Gtx 1070. The render I linked below took about 2 hours to render, it is 1700 by 956 pixels. Whether or not my render times are normal, what can I do to improve them? how does the render bucket size effect render times? What does the pixel reconstruction filter do? Does detail in camera/ crop region help?
Considering how long it took to render the linked photo, I would imagine that rendering a 4k image at higher settings would take more than 10 hours.

Linked image render settings:

Anti Aliasing: 4
Micro-Poly Detail: 0.78
Resolution: 1700 X 956 (i cropped it to fit the max size of the forum)
Bloom: On
Star Burst: On

Offline yossam

  • Member
  • *
  • Posts: 3072
Re: Terragen 4 performance
« Reply #1 on: May 28, 2017, 03:24:07 AM »
Actually 2 hours is not bad for your set-up and the settings you used for render. Also if that is the Alpine fractal you are using, it will be slow to render compared to a regular fractal terrain.  Welcome to the forum, BTW.  :)

Offline Dune

  • Terragen Alpha Tester (Win)
  • ***
  • Posts: 14448
    • www.ulco-art.nl
Re: Terragen 4 performance
« Reply #2 on: May 28, 2017, 06:39:09 AM »
Welcome indeed. Good to have a new user on board.
There are a lot of variables influencing render time, but I wouldn't start by changing variables like bucket size. Those are pretty much optimal at default. The filters make a harder or softer rendered image, so to say. If you use the search function and look for info on that subject, you'll find it. You can also test yourself in a crop render to see what the differences are. Very informative anyway to delve though older posts; there's a huge amount of experimentation and experience in those threads.
What Yossam says, the alpine shader is slower than others (due to internal computations), but things like transparent water (especially with a lot of displacement in waves), extreme displacements in land, easy clouds, compute terrains/normals after more than the usual number of nodes, and such, are also taking up quite some time.
My principle is to use as few as possible nodes and as few as compute terrains (in some circumstances a compute terrain is not needed at all, and that reduces rendertime). So build carefully and read and experiment a lot.
Btw. the max size on the forum is 6000px wide, so keep it below, and preferably in jpg.
« Last Edit: May 28, 2017, 06:40:52 AM by Dune »

Offline Ethrieltd

  • Member
  • *
  • Posts: 162
  • Well, here I am...
    • Youtube SFX Reels
Re: Terragen 4 performance
« Reply #3 on: May 28, 2017, 12:30:29 PM »
I'd say that it's normal for an image fitting those parameters.

I'd had some problems when starting out with HUGE render times. After reading some of the stuff here and trying things out managed to get them down to a "normal" level.

As Dune said, be careful of the settings in things like clouds/water, HIGH settings add lots of time for little benefit above a certain level.

I did a similar image to the one you've posted here

http://www.planetside.co.uk/forums/index.php/topic,23183.msg234775.html#msg234775

It has a couple more things (tree populations x3) and took a similar amount of time (2hrs 21mins if I recall correctly) on my i5 3470 with 16gb and an GT670.

So, I'd say you're looking at pretty normal performance in my opinion.

Offline Lieutenant-Dingo

  • Member
  • *
  • Posts: 2
Re: Terragen 4 performance
« Reply #4 on: May 28, 2017, 07:56:05 PM »
Thank you all so much for helping, and being so welcoming to me!
What Can I do to optimize clouds and water? Thank you

Offline Dune

  • Terragen Alpha Tester (Win)
  • ***
  • Posts: 14448
    • www.ulco-art.nl
Re: Terragen 4 performance
« Reply #5 on: May 29, 2017, 06:25:06 AM »
I don't know much about clouds, but in water; make sure you don't have excessive displacements, especially far from camera (you can mask out by distance shader), and don't use transparency if you don't need it. Mask out the areas where water is invisible (under terrain), which saves render time. If you search you'll find lots of interesting reads about this, like here: http://www.planetside.co.uk/forums/index.php/topic,22516.msg227050.html#msg227050 and here http://www.planetside.co.uk/forums/index.php/topic,8793.msg94183.html#msg94183

Offline Oshyan

  • Planetside Staff
  • *
  • Posts: 12665
  • Holy snagging ducks!
Re: Terragen 4 performance
« Reply #6 on: May 29, 2017, 10:11:48 PM »
I would guess that the render times in this image come mostly from the multiple v3 cloud layers (e.g. Easy Clouds), which all add quite a lot to render time when there are multiple layers in a scene (I see at least 3 layers), and also from the Alpine Shader as others mentioned. You could probably improve render times a little by lowering Micropoly Detail to 0.65, without losing much detail in the terrain; clouds would be unaffected, assuming you're using Defer Atmo, which is enabled in the Renderer by default.

We have some adjustments in development to hopefully speed up the rendering of multiple v3 cloud layers.

- Oshyan