Author Topic: TG4 tgo vs obj Texturing Problem  (Read 175 times)

Offline jaf

  • Member
  • *
  • Posts: 621
TG4 tgo vs obj Texturing Problem
« on: May 28, 2017, 12:51:25 AM »
I've been away from Terragen for a while and back now with TG4.  Amazing how much I've forgotten in just a year, but getting old doesn't help either.

Anyway, I've noticed the lower half of my tgo (objects) don't texture correctly (trunks of trees are simply light gray but upper half of trunks has the correct bark texture.  These are one's I purchased, like "HQ_PineTreeBundle-Commercial."  However, the obj of the same models look fine.  Is this due to a change in TG4 from TG3?

[edit] trunks not trucks
« Last Edit: May 28, 2017, 09:17:53 AM by jaf »
(6/14/17) Ryzen 1800x, 960 EVO 500GB NVME-M.2 SSD, Corsair Vengeance 64GB DDR4 3200 Mem,  EVGA GeForce GTX 1080 Ti FTW3 Graphics, Win 10 Pro x64, Terragen 4.0.04

Offline Dune

  • Member
  • *
  • Posts: 12196
  • Corkscrew Bird
    • www.ulco-art.nl
Re: TG4 tgo vs obj Texturing Problem
« Reply #1 on: May 28, 2017, 06:50:01 AM »
Strange! I've never encountered any change in that respect. Can you post an image?
In case you still haven't seen enough of my work: www.ulco-art.nl

Offline Hannes

  • Member
  • *
  • Posts: 3463
Re: TG4 tgo vs obj Texturing Problem
« Reply #2 on: May 28, 2017, 01:31:21 PM »
Me neither. However, did you try to load the obj, which looks good as you said, and save it as TGO? (I assume the TGOs that don't look correct are already in the package) If this works fine, it's probably a conversion problem that already came with the package.

Offline jaf

  • Member
  • *
  • Posts: 621
Re: TG4 tgo vs obj Texturing Problem
« Reply #3 on: May 28, 2017, 03:23:18 PM »
Thanks for the replies.  I'm going to recheck everything sometime today.  I jumped the gun in posting my signature with my new system and listed my new graphics card, a 1080 ti, which will be delivered sometime today.  I'm using my GTX 760 now. Can't wait to get the new card installed!

I did a quick test this morning.  The tree on the left is an obj and the right is a tgo.  Of course the obj is now showing the same problem that that tgo did yesterday.  It's a bit harder to see the problem, but it's there -- just below the first branching. 

I'll do more extensive test after I get my new graphics card today.   
(6/14/17) Ryzen 1800x, 960 EVO 500GB NVME-M.2 SSD, Corsair Vengeance 64GB DDR4 3200 Mem,  EVGA GeForce GTX 1080 Ti FTW3 Graphics, Win 10 Pro x64, Terragen 4.0.04

Offline jaf

  • Member
  • *
  • Posts: 621
Re: TG4 tgo vs obj Texturing Problem
« Reply #4 on: May 28, 2017, 05:13:40 PM »
Okay, Poseray to the rescue.  It's the model not TG4 -- it has a trunk1 and trunk2.  Trunk1 has an image map "Bark1" and trunk2 uses "Branch3b."  Used these models before and never noticed this.

(6/14/17) Ryzen 1800x, 960 EVO 500GB NVME-M.2 SSD, Corsair Vengeance 64GB DDR4 3200 Mem,  EVGA GeForce GTX 1080 Ti FTW3 Graphics, Win 10 Pro x64, Terragen 4.0.04

Offline jaf

  • Member
  • *
  • Posts: 621
Re: TG4 tgo vs obj Texturing Problem
« Reply #5 on: May 28, 2017, 05:20:09 PM »
.... and the lower half.  Guess it will be easy to change the images to one or the other for both trunks.
(6/14/17) Ryzen 1800x, 960 EVO 500GB NVME-M.2 SSD, Corsair Vengeance 64GB DDR4 3200 Mem,  EVGA GeForce GTX 1080 Ti FTW3 Graphics, Win 10 Pro x64, Terragen 4.0.04

Offline Dune

  • Member
  • *
  • Posts: 12196
  • Corkscrew Bird
    • www.ulco-art.nl
Re: TG4 tgo vs obj Texturing Problem
« Reply #6 on: May 29, 2017, 06:40:31 AM »
That would be simplest, but I wonder how they mapped this, perhaps with a smooth gradient mask?
In case you still haven't seen enough of my work: www.ulco-art.nl