Author Topic: Maya to Terragen fbx camera issue  (Read 219 times)

Offline shadow92

  • Member
  • *
  • Posts: 27
Maya to Terragen fbx camera issue
« on: April 12, 2017, 08:40:26 AM »
Hi,
I have encountered a strange issue while trying to find an effective way to do a camera matchmove between maya and terragen. I have an animated camera in maya, with just a few keyframes, baked and exported as an fbx. Camera movement ist not anything harsh, its basically a smooth movement forward with a slight swinging left and right and tilting in Z axis accordingly to add more realistic feel as it flies above the trees. When I rendered a quick lowpoly scene in terragen and overlayed it over my maya playblast to check the matchmove I noticed it suddenly makes a weird 360 turn around Y axis within a 3 frames and then it makes another quick 360 flip around X axis just a few frames later. Interesting, however, is the fact that if I chceck the camera animation in TG preview, no such a rolls and flips occur, even when I go frame by frame. Animation is smooth and exactly as it is supposed to be. When I render the problematic frame as a still, the problem persists, despite that camera in preview window is facing correct direction. Except that the matchmove appears to work like a charm (oh, and also somehow I had to multiply my focal length with 1,185 for some reason to make it fit) so I dont really understand where the problem is.
Have anyone encountered a similar issue or can reccomend me a better workaround to make maya/terragen matchmove possible?

Thanks for any help in advance
« Last Edit: April 12, 2017, 08:54:19 AM by shadow92 »

Offline Oshyan

  • Planetside Staff
  • *
  • Posts: 11476
  • Holy snagging ducks!
Re: Maya to Terragen fbx camera issue
« Reply #1 on: April 12, 2017, 07:43:56 PM »
This is a known issue with rotation order conversion. You can see here for a fix: http://www.planetside.co.uk/forums/index.php/topic,16017.msg156158.html#msg156158
What version of Terragen are you using?

- Oshyan