Author Topic: Xfrog plants rendering black  (Read 4527 times)

Offline Kieran Port

  • Member
  • *
  • Posts: 8
Xfrog plants rendering black
« on: February 23, 2012, 06:34:22 AM »
Hey, when ever I render any Xfrog plant, the free samples, they their leaves turn out black all the time. Does anyone have any solutions.
 

Offline TheBadger

  • Member
  • *
  • Posts: 7416
  • what's the difference?
Re: Xfrog plants rendering black
« Reply #1 on: February 23, 2012, 05:22:23 PM »
It sounds like your textures are not connected in the node. Or the alphas are corrupted. First check to be sure that the files are connected in the node.
It has been eaten.

Offline Kieran Port

  • Member
  • *
  • Posts: 8
Re: Xfrog plants rendering black
« Reply #2 on: February 24, 2012, 07:42:58 AM »
Thanks Ill try that

Offline Kieran Port

  • Member
  • *
  • Posts: 8
Re: Xfrog plants rendering black
« Reply #3 on: February 27, 2012, 04:28:27 AM »
Sorry to bug you again but i checked the node connections and they seemed to be alright except in lowest level they were not connected to each other or anything else. I tried to connect them together but it still didn't work so how exactly should they be connected up. If you could help me with this that would be great, thanks.

Offline jo

  • Planetside Staff
  • *
  • Posts: 1729
Re: Xfrog plants rendering black
« Reply #4 on: February 27, 2012, 05:50:01 AM »
Hi,

Could you post a screenshot of the part that doesn't look like it's hooked up right?

Regards,

Jo

Offline Kieran Port

  • Member
  • *
  • Posts: 8
Re: Xfrog plants rendering black
« Reply #5 on: February 28, 2012, 05:37:05 AM »
Hey sure thing,
The first one in the node Network level 1 and the second should be the Node Network level 3. The third is what my plant looks like what it should look like.




Thanks heaps,
Kieran

Offline Oshyan

  • Planetside Staff
  • *
  • Posts: 12462
  • Holy snagging ducks!
Re: Xfrog plants rendering black
« Reply #6 on: March 07, 2012, 03:10:09 AM »
Kieran, the pics aren't showing up on our end because you've linked using your local file system paths. I suggest uploading as attachments instead.

- Oshyan

Offline GioMez

  • Member
  • *
  • Posts: 216
Re: Xfrog plants rendering black
« Reply #7 on: March 07, 2012, 07:12:41 AM »
I had the same problem too with some new models: I found out that there was no reference to the alpha in the shaders within "Parts Shader"
I copied the name of the image from the box "Colour image" to the "Opacity image" one (in the form "Opacity") and checked "Use alpha channel"... I hope it works!

Offline rcallicotte

  • Member
  • *
  • Posts: 9542
Re: Xfrog plants rendering black
« Reply #8 on: March 07, 2012, 01:07:02 PM »
I have experience problems where the reference for the object in Terragen included an extra backslash and that prevented the image from being found via the MTL file.
So this is Disney World.  Can we live here?

Offline Kieran Port

  • Member
  • *
  • Posts: 8
Re: Xfrog plants rendering black
« Reply #9 on: April 16, 2012, 12:03:24 AM »
Hey,
Sorry it been a while but I had to go away and forgot about it. If anyone is still interested here are the images.
* Black render.png
* OC21_3_pers.jpge835af4f-0af5-46e8-9592-38114f2b696eLarge.jpg
* Node Network levle 1.PNG
* Node Network levle 3.PNG
Hopefully they work this time, I'm kind of new to Terragen Forums.
Thanks.

Offline masonspappy

  • Member
  • *
  • Posts: 1865
  • "I am my own worst-case scenario"
Re: Xfrog plants rendering black
« Reply #10 on: April 16, 2012, 01:01:17 AM »
Re: your first image showing "black" render, what I'm seeing is the leaf image surrounded by a black border. Which tells me you don't have a mask for you leaf image.  So what you need to do is:
- make a mask (same format, eg PNG, GIF or what ever as your original leaf)
- load the plant object into terragen
- on the left side of the screen highlight the object name, then select the "surface shader" tab beneath it.  click the box to the righ, and select "go to parts shader...."
- the parts shader box opens up.  click the box to "edit the internal node of this network"
- There will be one or more red box/grey box pairings.  Double-click the red box that corresponds to your leaf image.
- Another box opens up. select the "opacity" tab, then click the Open FOlder Icon on the "opacity image"line.  Navigate to the folder containing your mask  and load that mask.
Hopefully you'll now be able to render your image and see the leaves as they should be.
If that doesn't work, try cursing, threating the computer or banging your fist against the wall. Won't fix anything but sometimes that makes me feel better.  ;D
I know that images have an Alpha Chanel where you can load the mask and bypass the exercise above. But they don't much seem to work in Terragen, so I usually end up gong through the exercise above
« Last Edit: April 16, 2012, 06:08:06 AM by masonspappy »

Offline Walli

  • Member
  • *
  • Posts: 875
    • Wallis Eck
Re: Xfrog plants rendering black
« Reply #11 on: April 18, 2012, 01:49:58 PM »
Xfrog plants usually make use of textures with embedded alpha/opacity, so you just have to activate the according checkbox (use alpha channel)

Offline Kieran Port

  • Member
  • *
  • Posts: 8
Re: Xfrog plants rendering black
« Reply #12 on: April 23, 2012, 05:32:52 AM »
hi,
sorry I took a while to respond. I tried following the steps you, masonspappy, gave me but it didn't work :(. But that's probably just because I stuffed them up. I also tried Walli's idea and that worked :). Thanks to all of you guys for helping.
Thanks, Kieran