Author Topic: Ugly black spots  (Read 5897 times)

Offline David Burnett

  • Member
  • *
  • Posts: 86
Ugly black spots
« on: December 23, 2006, 11:53:17 AM »
Hi,
   After an over night render I looked at the resulting image and noticed there are a number of black pixels
on the image. I've attached a heavily compressed image in which I've highlighted a few places where you can
see them, but they are all over the coastlines. I've also attached the TGD file it way one is interested.

Dave

Offline oggyb

  • Member
  • *
  • Posts: 104
  • You think you've got a slow computer. . .
    • oggy at dA
Re: Ugly black spots
« Reply #1 on: December 23, 2006, 03:20:42 PM »
I have also seen these black spots in cloud layers and in the atmosphere.

M.

Offline Oshyan

  • Planetside Staff
  • *
  • Posts: 11877
  • Holy snagging ducks!
Re: Ugly black spots
« Reply #2 on: December 24, 2006, 12:36:25 AM »
I'm not getting the black spots in the .tgd you attached. Was it with these settings that you saw this error, or had you changed the scene since? My rendered result definitely looks different from yours. Are you perhaps on a Mac?

- Oshyan

Offline Cyber-Angel

  • Member
  • *
  • Posts: 960
Re: Ugly black spots
« Reply #3 on: December 24, 2006, 11:47:01 AM »
I have an idea that these black spots, may be due to detached terrain geometry floating in the preview, whereby as you may have noticed that when you move the camera in the preview the terrain in some places breaks apart along the edges and in some instances small fragments can remain even once the terrain has healed its self.

There maybe away to clean this up by writing some thing that could look for geometry that doesn’t belong in a certain place and clean it up, some how. The other alternative is to put in place a collision detection system into the drawing engine; this collision detection system would prevent you form been able to go through the terrain as you can now. Collision detection systems, such as these are commonly found in Flight Simulation Games to prevent you form passing through the terrain which you could once upon a time.

Regards to you.

Cyber-Angel   

Offline David Burnett

  • Member
  • *
  • Posts: 86
Re: Ugly black spots
« Reply #4 on: December 24, 2006, 03:11:35 PM »
I'm not getting the black spots in the .tgd you attached. Was it with these settings that you saw this error, or had you changed the scene since? My rendered result definitely looks different from yours. Are you perhaps on a Mac?

- Oshyan

I am on a mac, an intel iMac to be precise, but I've just done a crop render and no spots, I'll have a play with the settings see if I can bring them back. The last things I remember changing before doing a full render was to increase a few quality settings.

Dave

Offline Oshyan

  • Planetside Staff
  • *
  • Posts: 11877
  • Holy snagging ducks!
Re: Ugly black spots
« Reply #5 on: December 24, 2006, 07:53:02 PM »
Ok, thanks for looking into this David. These kind of render errors are annoying and do seem difficult to produce reliably. Hopefully you can get a scene file that will recreate them every time as that would help greatly in diagnoses.

- Oshyan

Offline David Burnett

  • Member
  • *
  • Posts: 86
Re: Ugly black spots
« Reply #6 on: December 24, 2006, 09:06:21 PM »
This one is seems to render with black spots, but I did not do a complete render as that takes over night (restartable renders would be a nice feature).

A completes crop render of
left 0.115625, right 0.40625
bottom 0.55,  top 0.66875 
shows they nicely.

Dave

Offline Oshyan

  • Planetside Staff
  • *
  • Posts: 11877
  • Holy snagging ducks!
Re: Ugly black spots
« Reply #7 on: December 24, 2006, 10:39:51 PM »
Is it safe to say this result is different from what you're getting?


Offline David Burnett

  • Member
  • *
  • Posts: 86
Re: Ugly black spots
« Reply #8 on: December 25, 2006, 12:07:39 AM »
Yes, mine looks like different.

Here's one where I just loaded the file I sent you, set the clip settings again and rendered,
it's blackspotclip.png.

Interestingly the black spots where not there mid render, that's the second attachment,
they appear as the land gets 'filled in'.

Dave

Offline Oshyan

  • Planetside Staff
  • *
  • Posts: 11877
  • Holy snagging ducks!
Re: Ugly black spots
« Reply #9 on: December 25, 2006, 12:08:43 AM »
Interesting. Looks like it may be a Mac-specific issue then. We'll look into it.

- Oshyan

 

anything